Kia K5 Forum banner
21 - 26 of 26 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #24 ·
I'm having the same issue and the lower radiator hose is cold
My radiator hoses were both the correct temperature. Im supposed to be getting my vehicle back today (it spent 8 days at the dealership). They said that the problem was air in the cooling system from the factory... They bled the cooling system 3 times and then have test driven it 30 miles "hard" and the problem seems to have been resolved. I will see if it is fixed during my 2 hour drive to thanksgiving dinner tomorrow...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #26 ·
My radiator hoses were both the correct temperature. Im supposed to be getting my vehicle back today (it spent 8 days at the dealership). They said that the problem was air in the cooling system from the factory... They bled the cooling system 3 times and then have test driven it 30 miles "hard" and the problem seems to have been resolved. I will see if it is fixed during my 2 hour drive to thanksgiving dinner tomorrow...
WELL...... was on my way home and it overheated again.... took the service manager on a test drive to show him in person the exact conditions that i can easily get it to overheat.. they told me they will have to have one of Kia's corporate engineers make a trip to the dealership to investigate further, they still dont understand what is going on. If this continues much longer without resolution i think ill see my options for a Lemon law buyback.
 
21 - 26 of 26 Posts
Top