Kia K5 Forum banner
1 - 20 of 23 Posts

Registered
Joined
154 Posts
Discussion Starter · #1 ·
Being good minding my own business b/c its raining. Cruise was set at 70. Stepped out in to the left lane to pass and it just went to shit. CEL kicked, power dropped. Couldn't even make 55 mph.

Limped to dealership in Evans GA (7 miles). Not my home store so no love and no loaner until they can diagnose it in 2-3 days.

馃槶 View attachment 1556
 

Registered
Joined
154 Posts
Discussion Starter · #7 ·
Kia Tech Line is still running through diagnostic / diagnosis process.

The dealer has sent 6 flights of data from over 25mi of test drives.

So far, the physical ignition system (coils, plugs) is ruled out. They began to troubleshoot the fuel delivery (injectors, connectors, etc) this afternoon. Still on the table is software and electrical (grounding issues have been cropping up on Carnival vans).

I wouldn't be surprised if the the fuel pipe recall check caused all this. When they verified the torque on the connector fittings they could have fractured the pipe or the connector.

The saga continues...
 

Registered
2021 Kia K5 GT
Joined
434 Posts
Kia Tech Line is still running through diagnostic / diagnosis process.

The dealer has sent 6 flights of data from over 25mi of test drives.

So far, the physical ignition system (coils, plugs) is ruled out. They began to troubleshoot the fuel delivery (injectors, connectors, etc) this afternoon. Still on the table is software and electrical (grounding issues have been cropping up on Carnival vans).

I wouldn't be surprised if the the fuel pipe recall check caused all this. When they verified the torque on the connector fittings they could have fractured the pipe or the connector.

The saga continues...
If it was the fuel line, you would've had fuel leaks. This is annoying me lol
 

Registered
Joined
154 Posts
Discussion Starter · #9 ·
[[/QUOTE]
If it was the fuel line, you would've had fuel leaks. This is annoying me lol
You would think... But if it was a hairline/stress crack it could be letting air in under load and staying closed enough to keep fuel in otherwise. But honestly just spit balling at this point...

Dress shirt Tie Sleeve Gesture Collar
 

Registered
Joined
154 Posts
Discussion Starter · #11 ·
So today is day 2 week 2 and there is still no diagnosis for the car. They have eliminated the fuel system and software from testing ATM. The Tech Line remains focused on ignition and electrical as the test drives keep demonstrating coil issues; however no root cause is evident.

They are finally going to put me in a rental by the end of week.
 

Registered
Joined
154 Posts
Discussion Starter · #16 ·
CHECK ENGINE LIGHT UNITS: 2.60 TECH(S):339 CUSTOMER STATES CHECK ENGINE LIGHT WAS ON, VEHICLE BEGAN RUNNING ROUGH HAS NO POWER

PULLED CODE P0301 MISFIRE ON CYLINDER #1 AND P034DFO MISFIRE DETECTED DURING FUEL SYSTEM A OPERATION. OPENED TECH LINE 14321411

SWAPPED COIL AND PLUG FROM #1 PLUG WENT TO #3 AND COIL WENT TO #4 AND RESET ADAPTIVE VALUES. TEST DROVE AND STILL HAD 1 MISFIRE ON #1. CHECKED THE RESISTANCE ON ALL INJECTORS. # 1-1.8 OHMS, #2- 1.8 OHMS, #3- 1.9 OHMS, AND #4-1.9 OHMS. ALL WERE IN SPEC. HAD MISFIRE ON #3 SWAPPED COILS FROM #2 TO #3. TEST INJECTOR DROP OUT FOR INJECTOR LEAK. NO LEAK. TESTED SPARK OUT OF COILS. SPARK WAS STRONG.

RESET ADAPTIVE VALUES AND ECVVT VALUES AND TEST DROVE APPROX 10 MILES CAR IS OPERATING NORMALLY AT THIS TIME
 
1 - 20 of 23 Posts
Top