Kia K5 Forum banner
1 - 20 of 32 Posts

·
Banned
Joined
·
127 Posts
Discussion Starter · #1 ·
April 2021 K5 Gt Line
I have an issue I have not seen on here yet and am looking for similarities To use when I go back to the dealer.
If I drive my car aggressively about 20 miles in sport mode on freeway. Then stop and put in park. The engine will stutter and soon after it will die. It sets no light on dash when this happens. Anyone else experience similar issue?

I saw the dealer with no help. Said they couldn’t duplicate. Standard dealer response when a tech doesn’t want to diagnose a problem .. I was in car business for almost 18 years.
any response would be great.
 

·
Registered
2021 Kia K5 GT-Line AWD
Joined
·
238 Posts
Gotcha. I agree with the dealer situation. It's a hit or miss with kia dealers. My dealer is great while others are not so good. They have to be more consistent if they want to be taken seriously.
Same here, my dealer has been pretty good. I had an issue with the sunroof in my old Optima, it took them a couple of tries, but they did figure it out. First they tried replacing the seal which worked for a day or 2. then they figured out the air was not venting through the trunk properly causing positive air pressure which was getting forced out through the sunroof seal.
 

·
Registered
2021 Kia K5 GT-Line AWD
Joined
·
1,177 Posts
Hey, has the problem been coming up when you have the A/C turned up then have it turned off? I know for a fact that for some reason, turning the A/C on Med or High then turning the A/C switch to off makes the engine sputter with the engine RPM going up and down like it can't find a stable RPM to idle at.

The only 2 ways I found to get around this is either just leaving the A/C on when you turn the car off, or set it to Low settings before turning the A/C off. The engine has an easier time finding a stable idle RPM that way.
 

·
Registered
2021 Kia K5 GT-Line
Joined
·
40 Posts
Hey, has the problem been coming up when you have the A/C turned up then have it turned off? I know for a fact that for some reason, turning the A/C on Med or High then turning the A/C switch to off makes the engine sputter with the engine RPM going up and down like it can't find a stable RPM to idle at.

The only 2 ways I found to get around this is either just leaving the A/C on when you turn the car off, or set it to Low settings before turning the A/C off. The engine has an easier time finding a stable idle RPM that way.
Man, you are fast on the reply, lol! I found that to be a sporadic issue as well recently, and your diagnosis is correct. Simmer down the AC slowly and then to off, and the engine won't stall. Similarily, while the A/C is in operation, the engine doesn't have any issue finding a stable idle if you turn the A/C off while in drive. Same if you turn your engine off without turning off the A/C, and upon start-up the engine finds a stable idle with the A/C turning on automatically just fine.
 

·
Registered
2021 Kia K5 GT-Line AWD
Joined
·
1,177 Posts
I mean, I was still 2 hours late to respond. lol I didn't try it out when the gear is in D but good to know that it doesn't sputter when in gear. I'm guessing that the low idle RPM of the engine when in Park is throwing the computer off somehow so it keeps revving the engine up to try to find the stable idle speed.
 

·
Registered
Joined
·
9 Posts
April 2021 K5 Gt Line
I have an issue I have not seen on here yet and am looking for similarities To use when I go back to the dealer.
If I drive my car aggressively about 20 miles in sport mode on freeway. Then stop and put in park. The engine will stutter and soon after it will die. It sets no light on dash when this happens. Anyone else experience similar issue?

I saw the dealer with no help. Said they couldn’t duplicate. Standard dealer response when a tech doesn’t want to diagnose a problem .. I was in car business for almost 18 years.
any response would be great.
 

·
Registered
Joined
·
9 Posts
April 2021 K5 Gt Line
I have an issue I have not seen on here yet and am looking for similarities To use when I go back to the dealer.
If I drive my car aggressively about 20 miles in sport mode on freeway. Then stop and put in park. The engine will stutter and soon after it will die. It sets no light on dash when this happens. Anyone else experience similar issue?

I saw the dealer with no help. Said they couldn’t duplicate. Standard dealer response when a tech doesn’t want to diagnose a problem .. I was in car business for almost 18 years.
any response would be great.
yup I just bought a 2022 k5GT line June 16,2021 and when my car shut off after pulling in a parking space and putting the gear in park I had just got done driving a bit aggressive. When I put it in park the idle got a bit rough went down then went rough again giving the car a little tremble then the engine die but of course all electric components stayed on so I turned the car off and waited just a few seconds and it started back up so I then went in reverse without adjusting anything (for example the AC, which was off) about 30ft or so and pulled back in and put it in park to see if I’d get the same result n I didn’t but after over the weeks I have had the AC on and parked it and got the cutoff again or sometimes it won’t cut off or I’ll give gas while in park n it won’t cut off so seeing some fellow owners noticing something with the AC being a common denominator I’m gonna keep an eye out but I’m going to the dealer 7/23/21 and I’ll show them what I gathered here and get back to you guys! sorry this was lengthy
 

·
Registered
Joined
·
9 Posts
Definitely understand I’m praying that with all the info I gathered and the car being out somewhat for a fair amount of time now this is a quick fix because I’m leaving for a 14hr road trip from Chicago to Texas on the 25th and really can’t afford for useless runarounds from the dealer or attitude because frankly they should take the cars back or defer-or-waive payments until they stop just pushing rushed products out there to the public that jeopardize our safety but that’s in a perfect world LOL they want our money at least give us genuine support when these problems arise though
 

·
Registered
Joined
·
9 Posts
On the 23rd the dealer told me they tried recreating the issue several times but got nothing and they checked the grounds and reported them being good the only reading they saw when scanning fir issues was for the navigation system but it only showed it happened once so they cleared it out and that was it I made it without problem on my 1000 mile road trip
 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top