Kia K5 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
So, after taking a beach trip over the weekend, it pushed my oil change timeline forward, so she's going in this coming Monday for her first 5k.

Obviously the oil change is due, and I'm going to have them look at my overboost issue with the turbo, and hopefully coming up with something for the MF'ing wind noise that was brutal for on a 3 hour drive. I will report with the findings so hopefully others can benefit.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #3 ·
Ok. Called the dealer since they couldn't be bothered to call me to tell me anything.

Oil change obviously had no issues.

As far as the Turbo, the tech said everything is "Functioning As Intended". Not the answer I'm looking for. I guess an aftermarket wastegate is in my near future.

As far as the Wind Noise, I was told basically to go pound sand and live with it. No fix for it, no fix in the works. Annoying. Guess we as a community can figure something out.
 

·
Registered
Joined
·
14 Posts
Ok. Called the dealer since they couldn't be bothered to call me to tell me anything.

Oil change obviously had no issues.

As far as the Turbo, the tech said everything is "Functioning As Intended". Not the answer I'm looking for. I guess an aftermarket wastegate is in my near future.

As far as the Wind Noise, I was told basically to go pound sand and live with it. No fix for it, no fix in the works. Annoying. Guess we as a community can figure something out.
my dealership said the same thing about the wind noise.. I guess I just making it up
 

·
Registered
Joined
·
58 Posts
As far as the Turbo, the tech said everything is "Functioning As Intended". Not the answer I'm looking for. I guess an aftermarket wastegate is in my near future.
How would you describe the problem with your turbo? 1st time with a turbo veh.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
How would you describe the problem with your turbo? 1st time with a turbo veh.
It feels like the vehicle is ready to run out from under you with the lightest pedal press. Basically, the Turbo pressure isn't "dumping" after driving at low RPM and sitting at idle, and when you go to accelerate, the turbo is spooled at low RPM and takes off, literally. I've seen this a lot in aftermarket setups when a wastegate isn't properly installed and the boost pressure doesn't dump without running out a gear.
 

·
Registered
Joined
·
58 Posts
It feels like the vehicle is ready to run out from under you with the lightest pedal press. Basically, the Turbo pressure isn't "dumping" after driving at low RPM and sitting at idle, and when you go to accelerate, the turbo is spooled at low RPM and takes off, literally. I've seen this a lot in aftermarket setups when a wastegate isn't properly installed and the boost pressure doesn't dump without running out a gear.
Thanks, have not noticed this on my gt-line, but, also not sure I love the smart mode, seems difficult to accelerate smoothly without tromping on it. I'm strating to use normal more and more.
 
1 - 7 of 7 Posts
Top