Kia K5 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
So I figured we could create this thread to list any type of known issues with the K5, and possible fixes/solutions.

I have a short list of bugs/issues that really got to me in the 6 months I've owned me GT-Line

1) Steering wheel rub, Steering wheel rubs when turning it. I thought nothing was going on with it, in fact the dealership realized it. Come to find out a bushing in the steering column was no good, so they replaced the entire column under warranty.

2) Glass issues, Windishield created a stress crack within 4 weeks of it. Kia tried to have me put it through insurance, but my insurance wouldn't cover it, and I wasn't going to pay for it. Kia insisted I paid for it even though there was no evidence of impact on the windshield and it clearly was a stress fracture which was created along my passenger side pillar and spread all the way across the windshield. This was a 2 month fight for me, but once I called corporate, sales ate the $1,100 price tag and replaced it as a warranty issue

3) Wind Noises, from what I hear anyone with a sunroof is hearing some pretty loud wind issues and there is no fix for it

4) Road Noise, I noticed more road noise than normal, kia has no suggestions to correct it aside from replacing my tires with a softer compounded rubber, no thanks lol

5) Paint issues, my fender has developed a rust spot right where it hits the headlight. No visible damage, the paint completely chipped off, currently the kia dealership went from "yeah we will definitely cover that" to "We need to wait to hear from corporate"...it's been a week. I'll update as I get more information.

6) Transmission issues, not really an "issue" but i noticed there is a serious delay with the AT when in normal mode with shifting between gears, to the point the car revs high as hell, the only fix Kia told me with this is to put it in sport mode and leave it in that for now on - One thing I noticed is when I take it out of AT and put it in techtronic, I can shift the car as needed. There is still a delay but it is a fraction of a second and once you get the hang of it, it's pretty easy to comfortably shift the car.

7) My girlfriend just noticed today that her button on her door doesn't work to unlock the car when pressed, but the fob works fine, I need to look into this to try to find a correction/resolution, has anyone else had this problem?

So here is the start of the thread lol if we have a valid resolution please comment below it as resolved along with the resolution. Has anyone else had any of these issues, and has anyone noticed any other problems?
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #3 ·
Thanks, good idea, following, should be a pinned thread! -- John
Thanks, I emailed the admin but they haven't been see on the forum in 15 days. So hopefully it will get pinned. If not I suppose I could always just try to bump it every now and then.
 

·
Registered
Joined
·
49 Posts
I have the EX and I've not had any of these problems. Owned it since August, so a little over 7mos, with just under 4K miles. The wind noise seems to be a rather common complaint, but I've not noticed that either.
 

·
Registered
2021 Kia K5 GT
Joined
·
129 Posts
I haven't noticed any wind noise on mine either. I do however hear some clicking coming from what I think sounds like a mount(doubtful) or normal dct characteristics. Shifts well with no sound at all. It's just at low speeds or when I'm coming to a stop I notice some very low click. No jerking or anything. Just seamless shifting.
 

·
Registered
2021 KIA K5
Joined
·
3 Posts
So I figured we could create this thread to list any type of known issues with the K5, and possible fixes/solutions.

I have a short list of bugs/issues that really got to me in the 6 months I've owned me GT-Line

1) Steering wheel rub, Steering wheel rubs when turning it. I thought nothing was going on with it, in fact the dealership realized it. Come to find out a bushing in the steering column was no good, so they replaced the entire column under warranty.

2) Glass issues, Windishield created a stress crack within 4 weeks of it. Kia tried to have me put it through insurance, but my insurance wouldn't cover it, and I wasn't going to pay for it. Kia insisted I paid for it even though there was no evidence of impact on the windshield and it clearly was a stress fracture which was created along my passenger side pillar and spread all the way across the windshield. This was a 2 month fight for me, but once I called corporate, sales ate the $1,100 price tag and replaced it as a warranty issue

3) Wind Noises, from what I hear anyone with a sunroof is hearing some pretty loud wind issues and there is no fix for it

4) Road Noise, I noticed more road noise than normal, kia has no suggestions to correct it aside from replacing my tires with a softer compounded rubber, no thanks lol

5) Paint issues, my fender has developed a rust spot right where it hits the headlight. No visible damage, the paint completely chipped off, currently the kia dealership went from "yeah we will definitely cover that" to "We need to wait to hear from corporate"...it's been a week. I'll update as I get more information.

6) Transmission issues, not really an "issue" but i noticed there is a serious delay with the AT when in normal mode with shifting between gears, to the point the car revs high as hell, the only fix Kia told me with this is to put it in sport mode and leave it in that for now on - One thing I noticed is when I take it out of AT and put it in techtronic, I can shift the car as needed. There is still a delay but it is a fraction of a second and once you get the hang of it, it's pretty easy to comfortably shift the car.

7) My girlfriend just noticed today that her button on her door doesn't work to unlock the car when pressed, but the fob works fine, I need to look into this to try to find a correction/resolution, has anyone else had this problem?

So here is the start of the thread lol if we have a valid resolution please comment below it as resolved along with the resolution. Has anyone else had any of these issues, and has anyone noticed any other problems?
I have another annoying issue ... a knocking or fake Turbo noise coming from the Engine ....
 

·
Registered
Joined
·
3 Posts
So I figured we could create this thread to list any type of known issues with the K5, and possible fixes/solutions.

I have a short list of bugs/issues that really got to me in the 6 months I've owned me GT-Line

1) Steering wheel rub, Steering wheel rubs when turning it. I thought nothing was going on with it, in fact the dealership realized it. Come to find out a bushing in the steering column was no good, so they replaced the entire column under warranty.

2) Glass issues, Windishield created a stress crack within 4 weeks of it. Kia tried to have me put it through insurance, but my insurance wouldn't cover it, and I wasn't going to pay for it. Kia insisted I paid for it even though there was no evidence of impact on the windshield and it clearly was a stress fracture which was created along my passenger side pillar and spread all the way across the windshield. This was a 2 month fight for me, but once I called corporate, sales ate the $1,100 price tag and replaced it as a warranty issue

3) Wind Noises, from what I hear anyone with a sunroof is hearing some pretty loud wind issues and there is no fix for it

4) Road Noise, I noticed more road noise than normal, kia has no suggestions to correct it aside from replacing my tires with a softer compounded rubber, no thanks lol

5) Paint issues, my fender has developed a rust spot right where it hits the headlight. No visible damage, the paint completely chipped off, currently the kia dealership went from "yeah we will definitely cover that" to "We need to wait to hear from corporate"...it's been a week. I'll update as I get more information.

6) Transmission issues, not really an "issue" but i noticed there is a serious delay with the AT when in normal mode with shifting between gears, to the point the car revs high as hell, the only fix Kia told me with this is to put it in sport mode and leave it in that for now on - One thing I noticed is when I take it out of AT and put it in techtronic, I can shift the car as needed. There is still a delay but it is a fraction of a second and once you get the hang of it, it's pretty easy to comfortably shift the car.

7) My girlfriend just noticed today that her button on her door doesn't work to unlock the car when pressed, but the fob works fine, I need to look into this to try to find a correction/resolution, has anyone else had this problem?

So here is the start of the thread lol if we have a valid resolution please comment below it as resolved along with the resolution. Has anyone else had any of these issues, and has anyone noticed any other problems?
I have been having issues with my Cruise Control, Emergency Braking, and Head on assist (not sure of the names to be exact). It comes and goes mensing it'll disable and enable at random times. I even restarted the infotainment system but it didn't make a difference. Has anyone had an issue like this if so please give me some suggestions. I have also disconnected the battery and reconnected it no difference.
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #9 ·
I have been having issues with my Cruise Control, Emergency Braking, and Head on assist (not sure of the names to be exact). It comes and goes mensing it'll disable and enable at random times. I even restarted the infotainment system but it didn't make a difference. Has anyone had an issue like this if so please give me some suggestions. I have also disconnected the battery and reconnected it no difference.
I haven't but I'd bring it to the dealership before your electrical and technology warranty expires
 

·
Registered
Joined
·
11 Posts
So I found the wind noise an issue but I generally find that it's the drivers window, it goes away when I crack the window very slightly. I need to call service to see if there isn't an adjustment on windows travel.

Yesterday when driving I had a weird issue in that I was accelerating, passing a car and the forward collision warning came on and changing something on the radio. The alert muted the audio but it didn't unmute for several miles until I was getting off the highway and crossed a white line entering the off ramp, then the audio came back normally. Super odd. I'm going to say it was just a perfect storm of coincidences.
 
1 - 11 of 11 Posts
Top